Pour nous contacter : soyez au rendez-vous sur IRC ! ⋅ Parcourir l'archive musicale Dogmazic ⋅ Notre Blog
Notre Documentation

bug affichage si config css2 + firefox < 1.5

13:35 modifié dans Le site V.2 beta
petit message informatif:
il y a un bug, signalé, dont certains d'entre vous pâtissent, et sur lequel notre équipe se blanchit les cheveux en ce moment :
sur firefox versions inférieures à 1.5, il semble y avoir un problème de gestion de la feuille de style ccs2 que nous employons ; d'abord ça s'afficherait correctement, puis une fois chargé ça se superpose illisiblement...

nous en sommes fâchés, très fâchés :
(- par le fait même du bug, totalement inattendu, ce n'est certes pas avec firefox que nous escomptions des bugs ,
- et puis, horresco referens, "on" nous trolle chez certains geeks, genre 'un site à contenu libre s'affichant mal sous navigo libre, et en plus ils osent mettre le bouton get firefox' ... c'est insupportable :twisted: )
donc nous nous en occupons activement : tous conseil, report de bug (os + browser etc), avis sont les bienvenus.
merci.

Réponses

  • d'autant que peu importe l'OS, nous sommes tous sur firefox comme navigateur par défaut.
    Pour éviter les soucis, téléchargez une version récente de firefox. Nous en sommes à la 1.5.0.7 je crois. Et la version 2 beta est déjà sortie.
  • Sous Mac OS 9.2.2 et Netscape 7.0 et mozilla 1.3 (oui je sais c'est obsolète !) j'ai quelque chose d'approchant.
    Tout va bien pendant un moment jusqu'à ce que je passe la souris sur le menu orange "musique- doc-actu-forums", tout semble brutalement se décaler vers le haut (sauf le menu orange lui-même) ce qui fait que le texte central se superpose avec les palettes du haut ("Mon compte", "ma musique" et "près de chez moi")...En rafraichissant, la page se redessine normalement et correctement, faut juste éviter de passer sur le menu orange (pratique !). Bref, je passe ma vie à rafraichir... :wink:

    Bon courage !
  • oui, idem avec le menu orange.
    moi je suis sous Red Hat 7.3 + Netscape 7.0

    j'ai remarqué que le décalage se produisait quand je passais sur ce menu en venant du bas (et pas du haut)...
  • ok, merci à vous, après avoir retourné la css, je sais d'où vient le problème.
    J'ai maintenant une css valide firefox et tout le reste sauf ... IE (pour changer).
  • dj3c1t écrit:
    j'ai remarqué que le décalage se produisait quand je passais sur ce menu en venant du bas (et pas du haut)...

    ... en fait non, c'est juste que ça dépend des pages et que je passais par le haut pour les pages où de toute façon ça se décalait pas.
  • mr_ersatz écrit:
    ok, merci à vous, après avoir retourné la css, je sais d'où vient le problème.
    J'ai maintenant une css valide firefox et tout le reste sauf ... IE (pour changer).
    ah bon, donc maintenant tout va bien ! :twisted:
  • mr_ersatz écrit:
    ok, merci à vous, après avoir retourné la css, je sais d'où vient le problème.
    J'ai maintenant une css valide firefox et tout le reste sauf ... IE (pour changer).
    Par curiosité (presque) professionnelle, c'était quoi exactement la source du machin ?
  • j'ai mis une nouvelle CSS normalement compatible avec Firefox <1.5 et IE.

    Pour Netscape 7, y a encore un bug d'affichage du logo qui est trop bas, mais déjà, c'est plus navigable. N'est-ce pas Pia et dj3c1t ?

    Dites si ça va mieux.
    Je suis sur mac os x, donc ce n'est pas forcément le plus représentatif.
    En bootant en windows, sous IE ça marche, mais parfois certaines bécanes ont d'autres comportements.
  • mpop écrit:
    Par curiosité (presque) professionnelle, c'était quoi exactement la source du machin ?
    le menu en float:right, déjà, le logo qui a des dimensions particulières, en fait, j'ai remanié pas mal de choses.
  • mr_ersatz écrit:
    Pour Netscape 7, y a encore un bug d'affichage du logo qui est trop bas

    oui, mais bon, là c'est pas vraiment génant. ça fait un peu curieux, mais ça gène pas la navigation.

    Par contre, je sais pas pour Pia, mais j'ai toujours le même décalage qui s'opère au passage de la souris au dessus du menu... :?

    mais j'avais déjà des problèmes d'affichage avec mon Netscape pour l'ancienne version du site. Là, je recommanderais d'attendre d'autres témoignages...

    Pia, ça se décale toujours pour toi ?
  • Non au premier contact, ça marche très bien (Netscape 7.0)... tout est nickel à part le logo supérieur gauche, totatlement décalé vers le bas... du coup l'autruche a disparu...mais ça empêche pas de vivre pleinement...
  • Sous Win XP, en regardant en vitesse comment ça se passe sous IE 6, tout semble impec. Mais ça m'a fait me rendre compte que sous Firefox 1.5.0.6 on ne voit que le haut du nom DOGMAZIC dans le logo (je croyais que c'était pour faire un genre) et que le texte en rouge en bas de la page est écrit trop gros et qu'il déborde sur le texte à droite.
    De plus, tant qu'on y est, les menus qui permettent de choisir un groupe ou un album, en haut à droite, sont bien affichés sous IE, mais débordent de la page sous Firefox, empéchant l'utilisation de la barre de défilement.
    Ah, toujours sous FF, un bug de l'ancien site a été conservé : quand on est dans la page d'un groupe, et après avoir lancé l'écoute d'un morceau, il y a parfois une barre de défilement horizontale qui apparait sans raison en bas de page, et qui plus est change de taille quand on balade la souris de gauche à droite (sans cliquer).
    Voilà, c'est tout pour aujourd'hui.
  • pia écrit:
    Non au premier contact, ça marche très bien (Netscape 7.0)...

    bon... ben ça doit être mon install qui délire.
    (j'avais déjà eu des trucs étranges auparavant...)
  • Ahhhh !!!!!

    mais oui, mais en fait non... (non, mais des fois....)

    rha, ces histoires de cache, non mais...
    ok. tout raffraichi, cache vidé et tout, je recharche le truc: nickel, no more prob avec le menu.
    (ouf...)
    (désolé si je vous ai fait speedé avec mon "bug" de la 4e dimention :oops: )
  • pia écrit:
    tout est nickel à part le logo supérieur gauche, totatlement décalé vers le bas... du coup l'autruche a disparu...

    mdr: l'autruche de dogmzic se cache la tête !

    mais y'en peut-être que ça fait un peu moins rire... :oops:

    bon, tout nickel, donc pour moi aussi, mis à part ce décalage vers le bas du logo en haut à gauche, qui se voit donc aussi sur Red Hat 7.3 + Netscape 7.0... Mais bon, là, j'en suis plus à des considérations esthétiques (qui ont, certes, leur importance, mais la page entière qui reste en place, ça me rend déjà pas mal plus zen).

Ajouter un commentaire